Printable Version | Subscribe | Add to Favourites
New Topic New Reply
Author: Subject: turbo oil leak help
jlayton

posted on 21/9/15 at 06:29 PM Reply With Quote
turbo oil leak help

as above I built my mk indy r1 turbo and worked very well from the off had it tuned and they mapped it to lean and melted 3 pstons
since then I bought another engine reduced the compression ratio (cometic head gasket 1.3mm and dialled cams) when I put it all back together for the first time I noticed oil leaking from the intake compressor on the turbo, I thought It was because I forgot to turn my oil scavenge pump on for a very short while. I still sent the car to the rollers to be re-tuned and it made 215bhp at the wheels and 120 ft lbs of torque but now oil is constantly leaking from the air filter on the turbo and leaking all into my intercooler, and out of my exhaust.
just wondering what your thoughts are as I have sent my new gt2860rs back to be checked/fixed. as if its a plumbing problem I don't want to brake another turbo. (first time it was mapped etc was fine which tells me the plumbing side of tings is right)

so would it be because I melted 3 pistons and that's damaged the seals on the turbo.

thanks in advance

View User's Profile View All Posts By User U2U Member
ian locostzx9rc2

posted on 21/9/15 at 07:06 PM Reply With Quote
Did you clean the oil out of the pipe work inter cooler etc after the engine blew ? If not it my just be all the oil from the old engine .
View User's Profile View All Posts By User U2U Member
jlayton

posted on 21/9/15 at 07:12 PM Reply With Quote
there was no oil in pipe work after engine blew. turbos done about 100 miles from new. the only thing I can think of is I run a oil scavenge pump and its on a illuminated switch on the dash, which the tuner was very forgetful with. and im sure it wouldn't take long to pressurise and blow the seals???
View User's Profile View All Posts By User U2U Member
dave_424

posted on 21/9/15 at 10:24 PM Reply With Quote
Is the routing of the oil lines the exact same as before?

Did you have a restrictor fitted in the oil feed line that you have forgotten or have you changed any of the oil feed/drain fittings?

View User's Profile View All Posts By User U2U Member
jlayton

posted on 22/9/15 at 06:21 AM Reply With Quote
Everything is the exact same as before and always ran a 1mm restrictor. I think tuner has forgot to turn scavenge pump on or could it of done damage when the old engine blow up as it popped the rocker gasket and through a load of oil out of it and melted 3 pistons
View User's Profile View All Posts By User U2U Member
dave_424

posted on 22/9/15 at 09:29 AM Reply With Quote
Are you sure that the scavenge pump is running? I would recommend wire the pump to come on using the oil pressure switch so it is always on when the engine is running so you can forget to switch it on.

[Edited on 22/9/15 by dave_424]

View User's Profile View All Posts By User U2U Member
jlayton

posted on 22/9/15 at 04:02 PM Reply With Quote
Yeah works definitely I wired it the way it is and was fine, but like I say the tuner was very forgetful with it y I was there . But the car was there for 3 weeks. Or can you get blow by when I blew the first engine could that of broke it .Those are the only 2 things I believe it could be as I ran it previously and was fine
View User's Profile View All Posts By User U2U Member
dave_424

posted on 22/9/15 at 04:54 PM Reply With Quote
I've had my turbo smoke when I accidentally blocked the crank case breather. Once fixed it returned to normal. People always seem to think that once a turbo smokes, the seals are knackered. The seals are actually just like piston rings so not much can really go wrong with them unless they are worn out. If the problem is fixed then it should go back to not smoking.

Was there excessive shaft play on the turbo?

Do you have a clear photo of your oil lines and turbo location?

View User's Profile View All Posts By User U2U Member
jlayton

posted on 22/9/15 at 06:37 PM Reply With Quote
Sorry I have not got any pictures of my set up. I have oil constantly coming out of the inlet compressor blades and also out the turning blades into the exhaust
View User's Profile View All Posts By User U2U Member
dave_424

posted on 22/9/15 at 06:45 PM Reply With Quote
If your oil lines are fine then iIwould agree that it's turbo seals. But something might have caused that within the 100 miles so could still be something wrong with your install.

The increased crank case pressure from you blowing your motor could have destroyed the seals

View User's Profile View All Posts By User U2U Member
jlayton

posted on 22/9/15 at 07:02 PM Reply With Quote
Cheers for your thoughts I hope the motor going last ttime is the problem. Otherwise it's going to be costing me more money just been out to garage took crankcase breather off to catch tank and all clear. May sound a bit thick here loll but when the pipe is attached and you blow and suck down the pipe you get suction is that right
View User's Profile View All Posts By User U2U Member
jlayton

posted on 28/9/15 at 07:16 PM Reply With Quote
Garrett say the oil feed and return must be 15 degrees from perpendicular to the ground. Mine was 36 does anyone know how much that would of restricted the drain ?
View User's Profile View All Posts By User U2U Member

New Topic New Reply


go to top






Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.