Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Running rich
dunky boy

posted on 9/4/14 at 09:21 PM Reply With Quote
Running rich

Hi. My mx5 1.6 engine with greddy turbo is running rich. Starts on the dot and runs smooth from cold then as it gets to 65c it changes tone and run rich. If i try to blip the throttle at this point it blows out black smoke. Once at 85c it runs smooth with a clean exhaust. Any ideas?

Cheers

Duncan

View User's Profile E-Mail User View All Posts By User U2U Member
britishtrident

posted on 10/4/14 at 06:38 AM Reply With Quote
The coolant temperature sensor that supplies the signal to the ECU is usually the first suspect.





[I] What use our work, Bennet, if we cannot care for those we love? .
― From BBC TV/Amazon's Ripper Street.
[/I]

View User's Profile View All Posts By User U2U Member
DW100

posted on 10/4/14 at 12:34 PM Reply With Quote
What's been done to tune it for the turbo set-up?

I had a look at a supercharged one once that had some sort of tuning card thing that adapted the signals from coolant and throttle position etc. The car ran terribly because it was all wired in wrong.

View User's Profile View All Posts By User U2U Member
dunky boy

posted on 10/4/14 at 10:30 PM Reply With Quote
Hi.

It certainly was running spot on so I suspect it's something that has gone wrong since set up. I did flush the coolant and change the air filter but nothing else. Will change the temp sensor and see what this does. Cheers Duncan

View User's Profile E-Mail User View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.