Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Megajolt help please.
po79

posted on 4/11/12 at 07:44 PM Reply With Quote
Megajolt help please.

Hi all,

I've got a megajolt lite jr (TPS) that I've been planning on fitting for well over a year.

I've got the all the ford stuff fitted and know it all works and fires but when I started to look at my megajolt unit I noticed a red wire (inside) that is wedged between the 16 pin plug and the body that isn't connected to any thing.

Is this a spare wire that is not required or do i need to get someone to take a look at it for me. obviously I don't want to connect it up if this is going to short the unit out!

Also does any one have any maps they could share with me someone kindly sent me some when i first got the megajolt but I lost them when my hard drive crashed. Its for a 2.0 Pinto with GP1 valves and bike carbs.

Many thanks in advance,

Poe.

View User's Profile View All Posts By User U2U Member
chillis

posted on 4/11/12 at 08:06 PM Reply With Quote
Probably best to post this on the Megajolt forum

http://www.autosportlabs.org/





Never under estimate the ingenuity of an idiot!

View User's Profile View All Posts By User U2U Member
Werner Van Loock

posted on 4/11/12 at 08:21 PM Reply With Quote
If it's the ground that is connected to the body, then i wouldn't mind, any other and I'd rectify it.







http://www.clubstylus.be

View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member   Werner+Van+Loock 's Aim   Werner+Van+Loock 's ICQ status This User Has MSN Messenger   Werner+Van+Loock 's Yahoo
po79

posted on 4/11/12 at 08:51 PM Reply With Quote
Cheers,

After i post this thread I took the ends off the unit and pulled the two curcuit boards out a little there is 3 wire insdie one blue, one black and the red one.

Blue and black are fitted to the bottom board but the red is wedge between the outside of the 16 pin connector and the top board it looks to have been placed there for a reason?

Poe.

View User's Profile View All Posts By User U2U Member
paulf

posted on 4/11/12 at 10:02 PM Reply With Quote
Its a long time since I did anything with megajolts but if it has 2 PCB s then it sounds as if the additional rev limiter module is fitted normally there is only one PCB, the wiring is most likely something to do with that.
Paul

View User's Profile View All Posts By User U2U Member
snapper

posted on 5/11/12 at 06:50 AM Reply With Quote
Autosportslabs has maps, the Pinto base map is a good start
You only need a modified map for a non standard cam and if the compression ratio is higher than standard by quite a bit
Once you have the engine starting, running clean at idle and getting 36 degrees all in at 3600 rpm then rolling road tune





I eat to survive
I drink to forget
I breath to pi55 my ex wife off (and now my ex partner)

View User's Profile View All Posts By User U2U Member
Autosri

posted on 5/11/12 at 11:23 AM Reply With Quote
If you pm me your email address il try and send all the pinto maps I have collected if you would like
View User's Profile View All Posts By User U2U Member
andyace

posted on 5/11/12 at 02:31 PM Reply With Quote
quote:
Originally posted by Autosri
If you pm me your email address il try and send all the pinto maps I have collected if you would like


Hi if u could send me those maps too that would be brill ... not at the mapping stage yet but would be good to have ready, thanks ... i have u2u'd my email address ... thanks again

View User's Profile View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.