Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: 2.0 Zetec turbo 1st start
Shooter63

posted on 28/6/20 at 03:40 PM Reply With Quote
2.0 Zetec turbo 1st start

Quite a decent day down the workshop, after a false start last week when the fuel rail decided to leak once the pump was turned on, ( 2 poxy £1.00 O rings) today O rings fitted the big moment came, fuel pump switch on, coil switch on, ECU switch on, turn the key, well bugger me the sod only started within a few seconds then sat there gently ticking over, a stab on the throttle and it cut out, TPS not recognised me thinks. Off to get the laptop and yup 0-0 , so do the slowly depress the throttle bit and save settings. Second fire up we have revs, teas all round ( I don't drink) . A good look round the engine bay etc no leaks, good stuff.
Then things go down hill a bit, I noticed the fuel pump screaming when you hit the throttle, it's being fed via 2no 10mm feeds then through a filter then to the pump, hopefully the filter is the strangle ( I'll have to read up on that one )
The next problem could be bigger to cure, I gave it some beans ( well you do don't you ) I'm only getting 5lb of boost at 5k revs, I was hoping for boost to kick in around 3.5k
As I said good and bad but at least it starts and runs

Shooter

View User's Profile View All Posts By User U2U Member
big_wasa

posted on 28/6/20 at 07:14 PM Reply With Quote
Have a look at some of Bailey performance posts. He recommends no pre filter unless itís a coarse screen type.

I had a clear pre pump filter on my test stand, you could see the fuel cavitating as the pump screamed.

Edit where is the vid ? I am always looking for ideas on cramming it all in

Current effort is trying to get a nose over the intercooler.





[Edited on 28/6/20 by big_wasa]

View User's Profile View All Posts By User U2U Member
Duncan Grier

posted on 29/6/20 at 05:19 PM Reply With Quote
Great work and looks a tidy conversion
View User's Profile View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content © 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [© 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.