Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Windows wifi help...
prawnabie

posted on 10/7/09 at 10:51 PM Reply With Quote
Windows wifi help...

Hi guys

My girlfriend has an eeepc that she uses at her house and at mine. Both locations have wifi but need the laptop to use a specified ip and default gateway address.

The ip address I can make the same at both loctions, but the defalut gateway is different at each location. Anyway i can get around thei using 1 wifi adapter?

Thanks

Shaun

View User's Profile View All Posts By User U2U Member
madmandegge

posted on 10/7/09 at 11:16 PM Reply With Quote
This may be possible using hardware profiles?

Taken from Windows Help:

"Open System in Control Panel.
On the Hardware tab, click Hardware Profiles.
Under Available hardware profiles, click the existing hardware profile you want, and do one of the following.

Click:
Copy to open the Copy Profile dialog box, and type a new name for the copy.
Rename to open the Rename Profile dialog box, and type a new name for the selected profile.
Delete to remove the selected profile."

Basically I'd set it up, name that profile then create a new profile and make the changes.

I may be totally wrong here! But I think it should work. If not, it may be possible to write a batch file to change the default gateway just by running one. If the above doesn't work I'll look into the other method.

View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 10/7/09 at 11:35 PM Reply With Quote
Why can't you just change the IP address of one of the gateways to match the other? Why does it need a static IP anyway? Most programs will accept 127.0.0.1 to refer to the local machine.






View User's Profile E-Mail User View All Posts By User U2U Member
prawnabie

posted on 10/7/09 at 11:38 PM Reply With Quote
How do I change the gateways? I need static ip and i use the laptop remotley
View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 10/7/09 at 11:43 PM Reply With Quote
All of the gateways that I've come across have had to ability to change their own IP address (with the exception of the BT Home Hub, which did change it's IP address but then poo itself). Somewhere buried in the system settings.

If you post the model of the gateway, I might be able to find the manual.






View User's Profile E-Mail User View All Posts By User U2U Member
prawnabie

posted on 10/7/09 at 11:48 PM Reply With Quote
Cheers, its a linksys WAG54GS
View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 10/7/09 at 11:54 PM Reply With Quote
Open web browser.

Type http://<address of gateway (192.168.1.1?)>/

Go to Setup > Basic Setup

Halfway down is "Local IP Address".

Change it to match the other gateway.






View User's Profile E-Mail User View All Posts By User U2U Member
prawnabie

posted on 11/7/09 at 12:06 AM Reply With Quote
ah im not sure thats what I need to change - the default gateway address isn't the same as that local ip address.

Shaun

View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 11/7/09 at 12:16 AM Reply With Quote
Unless you have a very strange setup, then it should be.

The Linksys default IP address is 192.168.1.1.

To get into the admin page, you need to visit http://192.168.1.1/

On your laptop, the static IP will be something else on the same subnet, like 192.168.1.2. It will need to have DNS servers specified, which will be 192.168.1.1, and the default gateway will need setting to 192.168.1.1.

In the gateway settings, the Local IP Address should match what is in the address bar, i.e. 192.168.1.1. This is the one to change.

There are other IP Address settings, but these are if you have a static IP address for the router. This will be something like 81.138.19.199 for example, but usually they are set to automatic.






View User's Profile E-Mail User View All Posts By User U2U Member
jeffw

posted on 11/7/09 at 07:34 AM Reply With Quote
Both WiFi devices will be using DHCP so I don't see what the issue is here ? Why do you need the same IP address at each location ?






View User's Profile View All Posts By User U2U Member
fov

posted on 11/7/09 at 08:12 AM Reply With Quote
Would a little VB or batch script do you?
You would need to run it every time you swap location.

View User's Profile View All Posts By User U2U Member
jeffw

posted on 11/7/09 at 08:30 AM Reply With Quote
Why bother....just run DHCP on the routers and the laptops and the situation fixes itself.






View User's Profile View All Posts By User U2U Member
Keith Weiland

posted on 11/7/09 at 10:58 AM Reply With Quote
I agree with Jeffw, why not just use DHCP? I can think of no reason on something like a netbook.
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member This User Has MSN Messenger
prawnabie

posted on 11/7/09 at 11:14 AM Reply With Quote
Hi

thanks for the replies!

The main problem is I use port forwarding at both locations to play games and run NAS units.

To do this I had to assign static ips to each device to stop them changing every time I switched them off.

In windows I had to manually assign the internal IP, subnet mask and default gateway.

The default gateway I just copied and pasted from the router and if i do this at each location I can connect to the net no probs. if i leave the default gateway set to the other router it comes up with an error in windows.

Default gateway here is something like 217.47.249.186. Like i said, if i leave this set into the netbook, it will not connect to the internet at the other loction until i change it!

Thanks

Shaun

View User's Profile View All Posts By User U2U Member
jeffw

posted on 11/7/09 at 02:13 PM Reply With Quote
I presume that you will not want the Notebook to be accessible form the net via port forwarding ? If so you can reduce the DHCP scope on each router so that it excludes your statically assigned devices and just use DHCP.

The other option (depending on how clever your routers are) is to use static assignements within DHCP by allocating a IP address to the specific MAC address of the WiFi card on the device. This will allow you to run DHCP on the network and for all the devices statically assigned to pick up their correct addresses regardless of the location.

If all else fails you can have two default gateway addresses on the netbook which will work on both networks, although it may slow it down a little when it first connects.

[Edited on 11/7/09 by jeffw]

[Edited on 11/7/09 by jeffw]






View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 11/7/09 at 03:38 PM Reply With Quote
The default gateway for devices internal to the network is not 217.47.249.186.

That is the gateway for the router to the BT network. If you have BT at one house, and a different ISP at the other house, this is why it isn't working. BT will only allow BT customers to access 217.47.249.186.

The default gateway for each of the internal devices should be set to the same IP address of the router. 192.168.1.1 is default for Linksys. 192.168.1.254 is default for BT equipment.

The idea is this:

If device A (192.168.1.10) tries to connect to device B (192.168.1.20), it recognises that device B is part of the same network connects directly to it.

If device A then tries to connect to Google (209.85.227.99), it recognises that Google is not part of the same network, and puts in a request to the gateway (which happens to be the broadband modem/router for most residential users), 192.168.1.254, to pass on the connection to Google. Your local gateway recognises that it needs to forward the request to ITS gateway, which is 217.47.249.186. The request keeps getting forwarded by the various bits of equipment until it eventually makes it to Google.

By setting the gateway on device A to 217.47.249.186, not 192.168.1.254, you are short-circuiting part of the system.

Set the gateway for your laptop to 192.168.1.254. Set both of your routers to have the IP address 192.168.1.254.

Lastly, make sure you pick a static IP for your laptop that is outside the range of the DHCP address pool. The address pool usually doesn't start til about 50, so low IP addresses are probably OK. I would suggest 192.168.1.10, 192.168.1.15, etc.






View User's Profile E-Mail User View All Posts By User U2U Member
jeffw

posted on 11/7/09 at 05:23 PM Reply With Quote
Ben

If he was using 217.47.249.186 it wouldn't work as the internal device would not be in the same subnet as the default gateway and therefore could not ARP for the MAC of the default gateway. He has to have been using the internal Interface IP of the router unless the router is in Layer 2 mode.

[Edited on 11/7/09 by jeffw]






View User's Profile View All Posts By User U2U Member
BenTyreman

posted on 11/7/09 at 07:16 PM Reply With Quote
quote:
Originally posted by prawnabie
The default gateway I just copied and pasted from the router and if i do this at each location I can connect to the net no probs. if i leave the default gateway set to the other router it comes up with an error in windows.

Default gateway here is something like 217.47.249.186.


jeffw, no disrespect but I was only going on the information provided to me. He claims that setting the gateway on the laptop to 217.47.249.186 DOES work at one site.

A quick bit of reading suggests that Windows has a built-in failsafe that attempts to correct for a misconfigured gateway address. I don't know exactly what magic goes on there, but apparently it does fix the problem so long as you use the router gateway address for that site, not the other site.

From what I read, he wants to use the laptop/NAS remotely. I would have thought that his intention for having a static IP on his laptop was so he COULD forward a port, not so that he couldn't.

I have stressed that the gateway on the laptop SHOULD be set to the same IP as the router, and that one router should have its IP address changed to match the other, so that he doesn't need to keep changing the settings when he moves from one site to another.






View User's Profile E-Mail User View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.